Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2010-4300

Published: 26 November 2010

Heap-based buffer overflow in the dissect_ldss_transfer function (epan/dissectors/packet-ldss.c) in the LDSS dissector in Wireshark 1.2.0 through 1.2.12 and 1.4.0 through 1.4.1 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via an LDSS packet with a long digest line that triggers memory corruption.

Priority

Medium

Status

Package Release Status
wireshark
Launchpad, Ubuntu, Debian
dapper Does not exist

hardy Ignored
(end of life)
karmic Ignored
(end of life)
lucid Ignored
(end of life)
maverick
Released (1.2.11-6build0.10.10.1)
natty Not vulnerable
(1.4.2-1)
oneiric Not vulnerable
(1.4.2-1)
precise Not vulnerable
(1.4.2-1)
quantal Not vulnerable
(1.4.2-1)
raring Not vulnerable
(1.4.2-1)
saucy Not vulnerable
(1.4.2-1)
upstream
Released (1.2.11-6, 1.4.2)
Patches:
upstream: http://anonsvn.wireshark.org/viewvc?view=revision&revision=34581