Your submission was sent successfully! Close

CVE-2010-4015

Published: 1 February 2011

Buffer overflow in the gettoken function in contrib/intarray/_int_bool.c in the intarray array module in PostgreSQL 9.0.x before 9.0.3, 8.4.x before 8.4.7, 8.3.x before 8.3.14, and 8.2.x before 8.2.20 allows remote authenticated users to cause a denial of service (crash) and possibly execute arbitrary code via integers with a large number of digits to unspecified functions.

Priority

Medium

Status

Package Release Status
postgresql-8.1
Launchpad, Ubuntu, Debian
dapper
Released (8.1.23-0ubuntu0.6.06.1)
hardy Does not exist

karmic Does not exist

lucid Does not exist

maverick Does not exist

natty Does not exist

upstream Needs triage

postgresql-8.3
Launchpad, Ubuntu, Debian
dapper Does not exist

hardy
Released (8.3.14-0ubuntu8.04)
karmic Ignored
(reached end-of-life)
lucid Does not exist

maverick Does not exist

natty Does not exist

upstream Needs triage

postgresql-8.4
Launchpad, Ubuntu, Debian
dapper Does not exist

hardy Does not exist

karmic
Released (8.4.7-0ubuntu0.9.10)
lucid
Released (8.4.7-0ubuntu0.10.04)
maverick
Released (8.4.7-0ubuntu0.10.10)
natty Not vulnerable
(8.4.7-1)
upstream Needs triage