Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2010-3573

Published: 19 October 2010

Unspecified vulnerability in the Networking component in Oracle Java SE and Java for Business 6 Update 21 and 5.0 Update 25 allows remote attackers to affect confidentiality, integrity, and availability via unknown vectors. NOTE: the previous information was obtained from the October 2010 CPU. Oracle has not commented on claims from a reliable downstream vendor that this is related to missing validation of request headers in the HttpURLConnection class when they are set by applets, which allows remote attackers to bypass the intended security policy.

From the Ubuntu Security Team

It was discovered that the HttpURLConnection class did not validate request headers set by java applets, which could allow an attacker to trigger actions otherwise not allowed to HTTP clients.

Notes

AuthorNote
sbeattie
red hat description: HttpURLConnection did not validate
request headers set by applets, which could allow remote attackers
to trigger actions otherwise restricted to HTTP clients.

Priority

Low

Status

Package Release Status
openjdk-6
Launchpad, Ubuntu, Debian
upstream Needs triage

dapper Does not exist

hardy
Released (1.8.2-4ubuntu1~8.04.1)
jaunty
Released (1.8.2-4ubuntu1~9.04.1)
karmic
Released (1.8.2-4ubuntu1~9.10.1)
lucid
Released (1.8.2-4ubuntu2)
maverick
Released (6b20-1.9.1-1ubuntu3)
sun-java6
Launchpad, Ubuntu, Debian
upstream Needs triage

dapper Does not exist

hardy
Released (6.22-0ubuntu1~8.04.1)
jaunty
Released (6.22-0ubuntu1~9.04.1)
karmic
Released (6.22-0ubuntu1~9.10.1)
lucid
Released (6.22-0ubuntu1~10.04)
maverick
Released (6.22-0ubuntu1~10.10)
openjdk-6b18
Launchpad, Ubuntu, Debian
upstream
Released (6b22)
dapper Does not exist

hardy Does not exist

intrepid Does not exist

karmic Not vulnerable
(6b18-1.8.4-0ubuntu1~9.10.1)
lucid Not vulnerable
(6b18-1.8.3-0ubuntu1~10.04.1)
maverick
Released (6b18-1.8.2-4ubuntu1)