CVE-2010-3567

Published: 19 October 2010

Unspecified vulnerability in the 2D component in Oracle Java SE and Java for Business 6 Update 21, and 5.0 Update 25 allows remote attackers to affect confidentiality, integrity, and availability via unknown vectors. NOTE: the previous information was obtained from the October 2010 CPU. Oracle has not commented on claims from a reliable downstream vendor that this is related to a calculation error in right-to-left text character counts for the ICU OpenType font rendering implementation, which triggers an out-of-bounds memory access.

From the Ubuntu security team

It was discovered that a miscalculation in the OpenType font rendering implementation would allow out-of-bounds memory access. This could allow an attacker to execute arbitrary code with the privileges of the user running a java application.

Priority

Low

Status

Package Release Status
openjdk-6
Launchpad, Ubuntu, Debian
Upstream Needs triage

openjdk-6b18
Launchpad, Ubuntu, Debian
Upstream
Released (6b22)
sun-java6
Launchpad, Ubuntu, Debian
Upstream Needs triage

Notes

AuthorNote
sbeattie
red hat description: Miscalculation in the OpenType font
rendering implementation caused out-of-bounds memory access, which
could allow remote attackers to execute code with the privileges
of the user running the java process.

References