Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2010-3192

Published: 14 October 2010

Certain run-time memory protection mechanisms in the GNU C Library (aka glibc or libc6) print argv[0] and backtrace information, which might allow context-dependent attackers to obtain sensitive information from process memory by executing an incorrect program, as demonstrated by a setuid program that contains a stack-based buffer overflow error, related to the __fortify_fail function in debug/fortify_fail.c, and the __stack_chk_fail (aka stack protection) and __chk_fail (aka FORTIFY_SOURCE) implementations.

Notes

AuthorNote
mdeslaur
upstream has closed this bug as "won't fix". Let's ignore this.
tyhicks
upstream has now fixed this CVE so I'm un-ignoring it. We need to
verify but we don't think we are vulnerable as we're already disabling the
stack trace.

Priority

Negligible

Status

Package Release Status
eglibc
Launchpad, Ubuntu, Debian
artful Does not exist

bionic Does not exist

cosmic Does not exist

disco Does not exist

eoan Does not exist

focal Does not exist

groovy Does not exist

hirsute Does not exist

impish Does not exist

jammy Does not exist

kinetic Does not exist

lunar Does not exist

mantic Does not exist

noble Does not exist

trusty Needed

upstream Needs triage

xenial Does not exist

zesty Does not exist

glibc
Launchpad, Ubuntu, Debian
artful Ignored
(end of life)
bionic Not vulnerable
(2.27-3ubuntu1)
cosmic Not vulnerable
(2.28-0ubuntu1)
disco Not vulnerable
(2.29-0ubuntu2)
eoan Not vulnerable
(2.29-0ubuntu2)
focal Not vulnerable
(2.29-0ubuntu2)
groovy Not vulnerable
(2.29-0ubuntu2)
hirsute Not vulnerable
(2.29-0ubuntu2)
impish Not vulnerable
(2.29-0ubuntu2)
jammy Not vulnerable
(2.29-0ubuntu2)
kinetic Not vulnerable
(2.29-0ubuntu2)
lunar Not vulnerable
(2.29-0ubuntu2)
mantic Not vulnerable
(2.29-0ubuntu2)
noble Not vulnerable
(2.29-0ubuntu2)
trusty Does not exist

upstream
Released (2.26)
xenial Needed

zesty Ignored
(end of life)
Patches:
upstream: https://sourceware.org/git/gitweb.cgi?p=glibc.git;h=ed421fca42fd9b4cab7c66e77894b8dd7ca57ed0