CVE-2010-2995

Published: 13 August 2010

The SigComp Universal Decompressor Virtual Machine (UDVM) in Wireshark 0.10.8 through 1.0.14 and 1.2.0 through 1.2.9 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via vectors related to sigcomp-udvm.c and an off-by-one error, which triggers a buffer overflow, different vulnerabilities than CVE-2010-2287.

Priority

Medium

Status

Package Release Status
ethereal
Launchpad, Ubuntu, Debian
Upstream
Released (1.0.15)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

wireshark
Launchpad, Ubuntu, Debian
Upstream
Released (1.2.10)
Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable
(1.2.10-1)
Patches:
Upstream: http://anonsvn.wireshark.org/viewvc?view=revision&revision=33087