CVE-2010-1614

Published: 29 April 2010

Multiple cross-site scripting (XSS) vulnerabilities in Moodle 1.8.x before 1.8.12 and 1.9.x before 1.9.8 allow remote attackers to inject arbitrary web script or HTML via vectors related to (1) the Login-As feature or (2) when the global search feature is enabled, unspecified global search forms in the Global Search Engine. NOTE: vector 1 might be resultant from a cross-site request forgery (CSRF) vulnerability.

Priority

Medium

Status

Package Release Status
moodle
Launchpad, Ubuntu, Debian
Upstream
Released (1.9.8)
Ubuntu 14.04 ESM (Trusty Tahr) Not vulnerable
(1.9.9.dfsg2-2)

Notes

AuthorNote
kees
MSA-10-0008 http://tracker.moodle.org/browse/MDL-21769

References