Your submission was sent successfully! Close

CVE-2010-0734

Published: 19 March 2010

content_encoding.c in libcurl 7.10.5 through 7.19.7, when zlib is enabled, does not properly restrict the amount of callback data sent to an application that requests automatic decompression, which might allow remote attackers to cause a denial of service (application crash) or have unspecified other impact by sending crafted compressed data to an application that relies on the intended data-length limit.

Priority

Low

Status

Package Release Status
curl
Launchpad, Ubuntu, Debian
Upstream
Released (7.20.0)
Patches:
Upstream: http://curl.haxx.se/libcurl-contentencoding.patch