Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2010-0050

Published: 15 March 2010

Use-after-free vulnerability in WebKit in Apple Safari before 4.0.5 allows remote attackers to execute arbitrary code or cause a denial of service (application crash) via an HTML document with improperly nested tags.

Notes

AuthorNote
jdstrand
qt4-x11 unmaintained upstream (see README.webkit for details)

Priority

Low

Cvss 3 Severity Score

8.8

Score breakdown

Status

Package Release Status
qt4-x11
Launchpad, Ubuntu, Debian
dapper Ignored
(end of life)
hardy Not vulnerable
(no webkit)
intrepid Ignored
(end of life, was needs-triage)
jaunty Ignored
(end of life)
karmic Ignored
(end of life)
lucid Ignored
(end of life)
maverick Not vulnerable
(webkit isn't built)
natty Not vulnerable
(webkit isn't built)
oneiric Not vulnerable
(webkit isn't built)
upstream Needs triage

webkit
Launchpad, Ubuntu, Debian
dapper Does not exist

hardy Ignored
(end of life)
intrepid Ignored
(end of life, was needed)
jaunty Ignored
(end of life)
karmic
Released (1.2.5-0ubuntu0.9.10.1)
lucid Not vulnerable
(1.1.90-1)
maverick Not vulnerable
(1.1.90-1)
natty Not vulnerable
(1.1.90-1)
oneiric Not vulnerable
(1.1.90-1)
upstream Needs triage

Patches:
upstream: http://trac.webkit.org/changeset/52073

Severity score breakdown

Parameter Value
Base score 8.8
Attack vector Network
Attack complexity Low
Privileges required None
User interaction Required
Scope Unchanged
Confidentiality High
Integrity impact High
Availability impact High
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H