Your submission was sent successfully! Close

CVE-2009-4897

Published: 12 May 2010

Buffer overflow in gs/psi/iscan.c in Ghostscript 8.64 and earlier allows remote attackers to execute arbitrary code or cause a denial of service (memory corruption) via a crafted PDF document containing a long name.

Priority

Medium

Status

Package Release Status
ghostscript
Launchpad, Ubuntu, Debian
dapper Does not exist

hardy
Released (8.61.dfsg.1-1ubuntu3.3)
intrepid Ignored
(reached end-of-life)
jaunty
Released (8.64.dfsg.1-0ubuntu8.1)
karmic Not vulnerable
(8.70.dfsg.1-0ubuntu3)
lucid Not vulnerable
(8.71.dfsg.1-0ubuntu5.1)
upstream
Released (8.70)
gs-afpl
Launchpad, Ubuntu, Debian
dapper Ignored
(reached end-of-life)
hardy Does not exist

intrepid Does not exist

jaunty Does not exist

karmic Does not exist

lucid Does not exist

upstream Needs triage

gs-esp
Launchpad, Ubuntu, Debian
dapper Not vulnerable
(doesn't reproduce)
hardy Does not exist

intrepid Does not exist

jaunty Does not exist

karmic Does not exist

lucid Does not exist

upstream Needs triage

gs-gpl
Launchpad, Ubuntu, Debian
dapper Ignored
(reached end-of-life)
hardy Does not exist

intrepid Does not exist

jaunty Does not exist

karmic Does not exist

lucid Does not exist

upstream Needs triage