Your submission was sent successfully! Close

CVE-2009-4261

Published: 21 December 2009

Multiple directory traversal vulnerabilities in the iallocator framework in Ganeti 1.2.4 through 1.2.8, 2.0.0 through 2.0.4, and 2.1.0 before 2.1.0~rc2 allow (1) remote attackers to execute arbitrary programs via a crafted external script name supplied through the HTTP remote API (RAPI) and allow (2) local users to execute arbitrary programs and gain privileges via a crafted external script name supplied through a gnt-* command, related to "path sanitization errors."

Priority

Medium

Status

Package Release Status
ganeti
Launchpad, Ubuntu, Debian
Upstream
Released (2.0.5)