CVE-2009-3288

Published: 22 September 2009

The sg_build_indirect function in drivers/scsi/sg.c in Linux kernel 2.6.28-rc1 through 2.6.31-rc8 uses an incorrect variable when accessing an array, which allows local users to cause a denial of service (kernel OOPS and NULL pointer dereference), as demonstrated by using xcdroast to duplicate a CD. NOTE: this is only exploitable by users who can open the cdrom device.

Priority

Medium

Status

Package Release Status
linux
Launchpad, Ubuntu, Debian
Upstream
Released (2.6.31)
Patches:
Proposed: http://lkml.org/lkml/2009/9/3/107
linux-source-2.6.15
Launchpad, Ubuntu, Debian
Upstream Not vulnerable