Your submission was sent successfully! Close

CVE-2009-3230

Published: 17 September 2009

The core server component in PostgreSQL 8.4 before 8.4.1, 8.3 before 8.3.8, 8.2 before 8.2.14, 8.1 before 8.1.18, 8.0 before 8.0.22, and 7.4 before 7.4.26 does not use the appropriate privileges for the (1) RESET ROLE and (2) RESET SESSION AUTHORIZATION operations, which allows remote authenticated users to gain privileges. NOTE: this is due to an incomplete fix for CVE-2007-6600.

Priority

Medium

Status

Package Release Status
postgresql-8.1
Launchpad, Ubuntu, Debian
dapper
Released (8.1.18-0ubuntu0.6.06)
hardy Does not exist

intrepid Does not exist

jaunty Does not exist

upstream
Released (8.1.18)
postgresql-8.3
Launchpad, Ubuntu, Debian
dapper Does not exist

hardy
Released (8.3.8-0ubuntu8.04)
intrepid
Released (8.3.8-0ubuntu8.10)
jaunty
Released (8.3.8-0ubuntu9.04)
upstream
Released (8.3.8)