Your submission was sent successfully! Close

CVE-2009-1956

Published: 08 June 2009

Off-by-one error in the apr_brigade_vprintf function in Apache APR-util before 1.3.5 on big-endian platforms allows remote attackers to obtain sensitive information or cause a denial of service (application crash) via crafted input.

Priority

Medium

Status

Package Release Status
apache2
Launchpad, Ubuntu, Debian
Upstream Needs triage

apr-util
Launchpad, Ubuntu, Debian
Upstream
Released (1.3.7+dfsg-1)
Patches:
Upstream: http://svn.apache.org/viewvc?view=rev&revision=768417