Your submission was sent successfully! Close

CVE-2009-1187

Published: 23 April 2009

Integer overflow in the JBIG2 decoding feature in Poppler before 0.10.6 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via vectors related to CairoOutputDev (CairoOutputDev.cc).

Priority

Medium

Status

Package Release Status
cups
Launchpad, Ubuntu, Debian
Upstream
Released (1.3.10)
cupsys
Launchpad, Ubuntu, Debian
Upstream
Released (1.3.10)
evince
Launchpad, Ubuntu, Debian
Upstream Not vulnerable
(linked to poppler)
gpdf
Launchpad, Ubuntu, Debian
Upstream Needs triage

ipe
Launchpad, Ubuntu, Debian
Upstream Needs triage

kdegraphics
Launchpad, Ubuntu, Debian
Upstream Needs triage

koffice
Launchpad, Ubuntu, Debian
Upstream Needs triage

libextractor
Launchpad, Ubuntu, Debian
Upstream Needs triage

pdfkit.framework
Launchpad, Ubuntu, Debian
Upstream Needs triage

pdftohtml
Launchpad, Ubuntu, Debian
Upstream Needs triage

poppler
Launchpad, Ubuntu, Debian
Upstream Needs triage

tetex-bin
Launchpad, Ubuntu, Debian
Upstream Needs triage

texlive-bin
Launchpad, Ubuntu, Debian
Upstream Needs triage

xpdf
Launchpad, Ubuntu, Debian
Upstream Needs triage

Notes

AuthorNote
jdstrand
CUPS on Ubuntu uses system pdftops (compiled with --disable-pdftops)

References