Your submission was sent successfully! Close

You have successfully unsubscribed! Close

Thank you for signing up for our newsletter!
In these regular emails you will find the latest updates about Ubuntu and upcoming events where you can meet our team.Close

CVE-2009-1151

Published: 26 March 2009

Static code injection vulnerability in setup.php in phpMyAdmin 2.11.x before 2.11.9.5 and 3.x before 3.1.3.1 allows remote attackers to inject arbitrary PHP code into a configuration file via the save action.

Notes

AuthorNote
mdeslaur
PoC: http://www.milw0rm.com/exploits/8921
other PoC: http://www.gnucitizen.org/blog/cve-2009-1151-phpmyadmin-remote-code-execution-proof-of-concept/

Priority

Medium

Cvss 3 Severity Score

9.8

Score breakdown

Status

Package Release Status
phpmyadmin
Launchpad, Ubuntu, Debian
dapper
Released (4:2.8.0.3-1ubuntu0.2)
gutsy Ignored
(end of life, was needed)
hardy
Released (4:2.11.3-1ubuntu1.2)
intrepid
Released (4:2.11.8.1-1ubuntu0.1)
jaunty Not vulnerable
(code not present)
karmic Not vulnerable
(code not present)
upstream Needs triage

Patches:
upstream: http://phpmyadmin.svn.sourceforge.net/viewvc/phpmyadmin/branches/MAINT_2_11_9/phpMyAdmin/scripts/setup.php?r1=11514&r2=12301&pathrev=12301
merge: https://code.launchpad.net/~ari-tczew/ubuntu/dapper/phpmyadmin/fix-CVE-2009-1151/+merge/23166

Severity score breakdown

Parameter Value
Base score 9.8
Attack vector Network
Attack complexity Low
Privileges required None
User interaction None
Scope Unchanged
Confidentiality High
Integrity impact High
Availability impact High
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H