Your submission was sent successfully! Close

CVE-2009-0799

Published: 23 April 2009

The JBIG2 decoder in Xpdf 3.02pl2 and earlier, CUPS 1.3.9 and earlier, Poppler before 0.10.6, and other products allows remote attackers to cause a denial of service (crash) via a crafted PDF file that triggers an out-of-bounds read.

Priority

Medium

Status

Package Release Status
cups
Launchpad, Ubuntu, Debian
Upstream
Released (1.3.10)
Ubuntu 21.10 (Impish Indri) Not vulnerable

Ubuntu 21.04 (Hirsute Hippo) Not vulnerable

Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable

Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable

Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was not-affected)
cupsys
Launchpad, Ubuntu, Debian
Upstream
Released (1.3.10)
Ubuntu 21.10 (Impish Indri) Does not exist

Ubuntu 21.04 (Hirsute Hippo) Does not exist

Ubuntu 20.04 LTS (Focal Fossa) Does not exist

Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

Ubuntu 16.04 ESM (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

evince
Launchpad, Ubuntu, Debian
Upstream Not vulnerable
(linked to poppler)
Ubuntu 21.10 (Impish Indri) Not vulnerable
(linked to poppler)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(linked to poppler)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(linked to poppler)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(linked to poppler)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(linked to poppler)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was not-affected [linked to poppler])
gpdf
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.10 (Impish Indri) Does not exist

Ubuntu 21.04 (Hirsute Hippo) Does not exist

Ubuntu 20.04 LTS (Focal Fossa) Does not exist

Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

Ubuntu 16.04 ESM (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

ipe
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.10 (Impish Indri) Not vulnerable
(uses system pdflatex)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(uses system pdflatex)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(uses system pdflatex)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(uses system pdflatex)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(uses system pdflatex)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was not-affected [uses system pdflatex])
kdegraphics
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.10 (Impish Indri) Does not exist

Ubuntu 21.04 (Hirsute Hippo) Does not exist

Ubuntu 20.04 LTS (Focal Fossa) Does not exist

Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

Ubuntu 16.04 ESM (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

koffice
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.10 (Impish Indri) Does not exist

Ubuntu 21.04 (Hirsute Hippo) Does not exist

Ubuntu 20.04 LTS (Focal Fossa) Does not exist

Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

Ubuntu 16.04 ESM (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

libextractor
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.10 (Impish Indri) Needs triage

Ubuntu 21.04 (Hirsute Hippo) Needs triage

Ubuntu 20.04 LTS (Focal Fossa) Needs triage

Ubuntu 18.04 LTS (Bionic Beaver) Needs triage

Ubuntu 16.04 ESM (Xenial Xerus) Ignored
(end of standard support, was needs-triage)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was needs-triage)
pdfkit.framework
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.10 (Impish Indri) Does not exist

Ubuntu 21.04 (Hirsute Hippo) Does not exist

Ubuntu 20.04 LTS (Focal Fossa) Does not exist

Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

Ubuntu 16.04 ESM (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

pdftohtml
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.10 (Impish Indri) Does not exist

Ubuntu 21.04 (Hirsute Hippo) Does not exist

Ubuntu 20.04 LTS (Focal Fossa) Does not exist

Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

Ubuntu 16.04 ESM (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

poppler
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.10 (Impish Indri)
Released (0.10.5-1ubuntu2)
Ubuntu 21.04 (Hirsute Hippo)
Released (0.10.5-1ubuntu2)
Ubuntu 20.04 LTS (Focal Fossa)
Released (0.10.5-1ubuntu2)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (0.10.5-1ubuntu2)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (0.10.5-1ubuntu2)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was released [0.10.5-1ubuntu2])
tetex-bin
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.10 (Impish Indri) Does not exist

Ubuntu 21.04 (Hirsute Hippo) Does not exist

Ubuntu 20.04 LTS (Focal Fossa) Does not exist

Ubuntu 18.04 LTS (Bionic Beaver) Does not exist

Ubuntu 16.04 ESM (Xenial Xerus) Does not exist

Ubuntu 14.04 ESM (Trusty Tahr) Does not exist

texlive-bin
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.10 (Impish Indri) Not vulnerable
(linked to poppler)
Ubuntu 21.04 (Hirsute Hippo) Not vulnerable
(linked to poppler)
Ubuntu 20.04 LTS (Focal Fossa) Not vulnerable
(linked to poppler)
Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(linked to poppler)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(linked to poppler)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was not-affected [linked to poppler])
xpdf
Launchpad, Ubuntu, Debian
Upstream
Released (3.02-2)
Ubuntu 21.10 (Impish Indri) Not vulnerable

Ubuntu 21.04 (Hirsute Hippo) Not vulnerable

Ubuntu 20.04 LTS (Focal Fossa) Does not exist

Ubuntu 18.04 LTS (Bionic Beaver) Not vulnerable
(3.02-2)
Ubuntu 16.04 ESM (Xenial Xerus) Not vulnerable
(3.02-2)
Ubuntu 14.04 ESM (Trusty Tahr) Does not exist
(trusty was not-affected [3.02-2])

Notes

AuthorNote
jdstrand
CUPS on Ubuntu uses system pdftops (compiled with --disable-pdftops)
sbeattie
ipe uses system pdflatex

References