Your submission was sent successfully! Close

CVE-2009-0583

Published: 23 March 2009

Multiple integer overflows in icc.c in the International Color Consortium (ICC) Format library (aka icclib), as used in Ghostscript 8.64 and earlier and Argyll Color Management System (CMS) 1.0.3 and earlier, allow context-dependent attackers to cause a denial of service (heap-based buffer overflow and application crash) or possibly execute arbitrary code by using a device file for a translation request that operates on a crafted image file and targets a certain "native color space," related to an ICC profile in a (1) PostScript or (2) PDF file with embedded images.

Priority

Medium

Status

Package Release Status
ghostscript
Launchpad, Ubuntu, Debian
dapper Does not exist

gutsy
Released (8.61.dfsg.1~svn8187-0ubuntu3.5)
hardy
Released (8.61.dfsg.1-1ubuntu3.1)
intrepid
Released (8.63.dfsg.1-0ubuntu6.3)
upstream Needs triage

gs-gpl
Launchpad, Ubuntu, Debian
dapper
Released (8.15-4ubuntu3.2)
gutsy Does not exist

hardy Does not exist

intrepid Does not exist

upstream Needs triage