Your submission was sent successfully! Close

CVE-2008-5557

Published: 23 December 2008

Heap-based buffer overflow in ext/mbstring/libmbfl/filters/mbfilter_htmlent.c in the mbstring extension in PHP 4.3.0 through 5.2.6 allows context-dependent attackers to execute arbitrary code via a crafted string containing an HTML entity, which is not properly handled during Unicode conversion, related to the (1) mb_convert_encoding, (2) mb_check_encoding, (3) mb_convert_variables, and (4) mb_parse_str functions.

Notes

AuthorNote
mdeslaur
reproducer in php.net bug
Priority

Medium

Status

Package Release Status
php4
Launchpad, Ubuntu, Debian
dapper Ignored
(reached end-of-life)
gutsy Does not exist

hardy Does not exist

intrepid Does not exist

jaunty Does not exist

karmic Does not exist

upstream Needs triage

php5
Launchpad, Ubuntu, Debian
dapper
Released (5.1.2-1ubuntu3.13)
gutsy
Released (5.2.3-1ubuntu6.5)
hardy
Released (5.2.4-2ubuntu5.5)
intrepid
Released (5.2.6-2ubuntu4.1)
jaunty Not vulnerable
(5.2.6.dfsg.1-3ubuntu2)
karmic Not vulnerable
(5.2.6.dfsg.1-3ubuntu2)
upstream
Released (5.2.6.dfsg.1-1)
Patches:
vendor: http://patch-tracking.debian.net/patch/series/view/php5/5.2.6.dfsg.1-2/CVE-2008-5557.patch
upstream: http://cvs.php.net/viewvc.cgi/php-src/ext/mbstring/libmbfl/filters/mbfilter_htmlent.c?hideattic=0&r1=1.7&r2=1.8