Your submission was sent successfully! Close

CVE-2008-3142

Published: 1 August 2008

Multiple buffer overflows in Python 2.5.2 and earlier on 32bit platforms allow context-dependent attackers to cause a denial of service (crash) or have unspecified other impact via a long string that leads to incorrect memory allocation during Unicode string processing, related to the unicode_resize function and the PyMem_RESIZE macro.

Priority

Medium

Status

Package Release Status
python2.4
Launchpad, Ubuntu, Debian
dapper
Released (2.4.3-0ubuntu6.2)
feisty
Released (2.4.4-2ubuntu7.2)
gutsy
Released (2.4.4-6ubuntu4.2)
hardy
Released (2.4.5-1ubuntu4.1)
upstream
Released (2.4.5-5)
Patches:
upstream: http://svn.python.org/view?rev=65262&view=rev

python2.5
Launchpad, Ubuntu, Debian
dapper Does not exist

feisty
Released (2.5.1-0ubuntu1.2)
gutsy
Released (2.5.1-5ubuntu5.2)
hardy
Released (2.5.2-2ubuntu4.1)
upstream
Released (2.5.2-10)
Patches:

upstream: http://svn.python.org/view?rev=65261&view=rev