Your submission was sent successfully! Close

CVE-2008-1514

Published: 26 March 2008

arch/s390/kernel/ptrace.c in Linux kernel 2.6.9, and other versions before 2.6.27-rc6, on s390 platforms allows local users to cause a denial of service (kernel panic) via the user-area-padding test from the ptrace testsuite in 31-bit mode, which triggers an invalid dereference.

Priority

Medium

Status

Package Release Status
linux
Launchpad, Ubuntu, Debian
dapper Does not exist

edgy Does not exist

feisty Does not exist

gutsy Does not exist

hardy Not vulnerable

upstream Needs triage

linux-source-2.6.15
Launchpad, Ubuntu, Debian
dapper Not vulnerable

edgy Does not exist

feisty Does not exist

gutsy Does not exist

hardy Does not exist

upstream Needs triage

linux-source-2.6.17
Launchpad, Ubuntu, Debian
dapper Does not exist

edgy Not vulnerable

feisty Does not exist

gutsy Does not exist

hardy Does not exist

upstream Needs triage

linux-source-2.6.20
Launchpad, Ubuntu, Debian
dapper Does not exist

edgy Does not exist

feisty Not vulnerable

gutsy Does not exist

hardy Does not exist

upstream Needs triage

linux-source-2.6.22
Launchpad, Ubuntu, Debian
dapper Does not exist

edgy Does not exist

feisty Does not exist

gutsy Not vulnerable

hardy Does not exist

upstream Needs triage

Notes

AuthorNote
jdstrand
s390 specific according to: http://sourceware.org/systemtap/wiki/utrace/tests

References

Bugs