CVE-2008-0731

Published: 12 February 2008

The Linux kernel before 2.6.18.8-0.8 in SUSE openSUSE 10.2 does not properly handle failure of an AppArmor change_hat system call, which might allow attackers to trigger the unconfining of an apparmored task.

Priority

Low

Status

Package Release Status
linux
Launchpad, Ubuntu, Debian
Upstream Not vulnerable

linux-source-2.6.15
Launchpad, Ubuntu, Debian
Upstream Not vulnerable

linux-source-2.6.17
Launchpad, Ubuntu, Debian
Upstream Not vulnerable

linux-source-2.6.20
Launchpad, Ubuntu, Debian
Upstream Not vulnerable

linux-source-2.6.22
Launchpad, Ubuntu, Debian
Upstream Not vulnerable

Notes

AuthorNote
jdstrand
apparmor in OpenSUSE kernels < 2.6.18.8-0.8.  needed

References