Your submission was sent successfully! Close

CVE-2007-5938

Published: 6 December 2007

The iwl_set_rate function in compatible/iwl3945-base.c in iwlwifi 1.1.21 and earlier dereferences an iwl_get_hw_mode return value without checking for NULL, which might allow remote attackers to cause a denial of service (kernel panic) via unspecified vectors during module initialization.

Priority

Low

Status

Package Release Status
linux
Launchpad, Ubuntu, Debian
dapper Does not exist

edgy Does not exist

feisty Does not exist

gutsy Does not exist

hardy Not vulnerable
(2.6.24-4.7)
upstream Needed

linux-source-2.6.15
Launchpad, Ubuntu, Debian
dapper Not vulnerable
(code not present)
edgy Does not exist

feisty Does not exist

gutsy Does not exist

hardy Does not exist

upstream Needed

linux-source-2.6.17
Launchpad, Ubuntu, Debian
dapper Does not exist

edgy Not vulnerable
(code not present)
feisty Does not exist

gutsy Does not exist

hardy Does not exist

upstream Needed

linux-source-2.6.20
Launchpad, Ubuntu, Debian
dapper Does not exist

edgy Does not exist

feisty Not vulnerable
(code not present)
gutsy Does not exist

hardy Does not exist

upstream Needed

linux-source-2.6.22
Launchpad, Ubuntu, Debian
dapper Does not exist

edgy Does not exist

feisty Does not exist

gutsy Not vulnerable
(code not present)
hardy Does not exist

upstream Needed