CVE-2007-5162

Published: 01 October 2007

The connect method in lib/net/http.rb in the (1) Net::HTTP and (2) Net::HTTPS libraries in Ruby 1.8.5 and 1.8.6 does not verify that the commonName (CN) field in a server certificate matches the domain name in an HTTPS request, which makes it easier for remote attackers to intercept SSL transmissions via a man-in-the-middle attack or spoofed web site.

Priority

Low

Status

Package Release Status
libopenssl-ruby
Launchpad, Ubuntu, Debian
Upstream
Released (0.1.4a-1sarge1)
ruby1.8
Launchpad, Ubuntu, Debian
Upstream
Released (1.8.6.111)
Patches:
Debdiff: https://bugs.launchpad.net/ubuntu/+source/ruby1.8/+bug/149616