Your submission was sent successfully! Close

You have successfully unsubscribed! Close

CVE-2007-3476

Published: 28 June 2007

Array index error in gd_gif_in.c in the GD Graphics Library (libgd) before 2.0.35 allows user-assisted remote attackers to cause a denial of service (crash and heap corruption) via large color index values in crafted image data, which results in a segmentation fault.

Priority

Low

Status

Package Release Status
libgd2
Launchpad, Ubuntu, Debian
dapper
Released (2.0.33-2ubuntu5.4)
edgy Ignored
(end of life, was needed)
feisty Ignored
(end of life, was needed)
gutsy Ignored
(end of life, was needed)
hardy Not vulnerable
(2.0.35.dfsg-3ubuntu2)
intrepid Not vulnerable
(2.0.35.dfsg-3ubuntu2)
jaunty Not vulnerable
(2.0.35.dfsg-3ubuntu2)
karmic Not vulnerable
(2.0.35.dfsg-3ubuntu2)
upstream
Released (2.0.35)
Patches:
vendor: https://rhn.redhat.com/errata/RHSA-2008-0146.html
upstream: http://cvs.php.net/viewvc.cgi/php-src/ext/gd/libgd/gd_gif_in.c?r1=1.2.2.2.6.3&r2=1.2.2.2.6.4