Your submission was sent successfully! Close

CVE-2007-2172

Published: 22 April 2007

A typo in Linux kernel 2.6 before 2.6.21-rc6 and 2.4 before 2.4.35 causes RTA_MAX to be used as an array size instead of RTN_MAX, which leads to an "out of bound access" by the (1) dn_fib_props (dn_fib.c, DECNet) and (2) fib_props (fib_semantics.c, IPv4) functions.

Priority

Unknown

Status

Package Release Status
linux-source-2.6.15
Launchpad, Ubuntu, Debian
dapper
Released (2.6.15-29.58)
edgy Does not exist

feisty Does not exist

upstream Needs triage

linux-source-2.6.17
Launchpad, Ubuntu, Debian
dapper Does not exist

edgy
Released (2.6.17.1-12.40)
feisty Does not exist

upstream Needs triage

linux-source-2.6.20
Launchpad, Ubuntu, Debian
dapper Does not exist

edgy Does not exist

feisty
Released (2.6.20-16.31)
upstream Needs triage