Your submission was sent successfully! Close

CVE-2006-4790

Published: 14 September 2006

verify.c in GnuTLS before 1.4.4, when using an RSA key with exponent 3, does not properly handle excess data in the digestAlgorithm.parameters field when generating a hash, which allows remote attackers to forge a PKCS #1 v1.5 signature that is signed by that RSA key and prevents GnuTLS from correctly verifying X.509 and other certificates that use PKCS, a variant of CVE-2006-4339.

Priority

Unknown

Status

Package Release Status
gnutls11
Launchpad, Ubuntu, Debian
dapper
Released (1.0.16-14ubuntu1.1)
edgy Does not exist

feisty Does not exist

upstream Needs triage

gnutls12
Launchpad, Ubuntu, Debian
dapper
Released (1.2.9-2ubuntu1.1)
edgy
Released (1.2.11-2ubuntu1)
feisty Does not exist

upstream Needs triage

gnutls13
Launchpad, Ubuntu, Debian
dapper Does not exist

edgy
Released (1.4.0-3ubuntu1)
feisty
Released (1.4.0-3ubuntu1)
upstream Needs triage