Your submission was sent successfully! Close

CVE-2006-1990

Published: 24 April 2006

Integer overflow in the wordwrap function in string.c in PHP 4.4.2 and 5.1.2 might allow context-dependent attackers to execute arbitrary code via certain long arguments that cause a small buffer to be allocated, which triggers a heap-based buffer overflow in a memcpy function call, a different vulnerability than CVE-2002-1396.

Priority

Unknown

Status

Package Release Status
php4
Launchpad, Ubuntu, Debian
dapper Ignored
(reached end-of-life)
edgy
Released (4.4.2-1.1)
feisty Does not exist

gutsy Does not exist

hardy Does not exist

intrepid Does not exist

jaunty Does not exist

karmic Does not exist

upstream Needs triage

php5
Launchpad, Ubuntu, Debian
dapper
Released (5.1.2-1ubuntu3.9)
edgy
Released (5.1.6-1ubuntu2.6)
feisty
Released (5.2.1-0ubuntu1.4)
gutsy
Released (5.2.3-1ubuntu5)
hardy
Released (5.2.3-1ubuntu5)
intrepid
Released (5.2.3-1ubuntu5)
jaunty
Released (5.2.3-1ubuntu5)
karmic
Released (5.2.3-1ubuntu5)
upstream Needs triage