USN-538-1: libpng vulnerabilities

25 October 2007

libpng vulnerabilities

Releases

Packages

  • libpng -

Details

It was discovered that libpng did not properly perform bounds checking
and comparisons in certain operations. An attacker could send a specially
crafted PNG image and cause a denial of service in applications linked
against libpng.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 7.10
Ubuntu 7.04
Ubuntu 6.10
Ubuntu 6.06

After a standard system upgrade you need to reboot your computer to
effect the necessary changes.