USN-4535-1: RDFLib vulnerability

23 September 2020

RDFLib could be made to made to execute arbitrary code if it were running in a directory with a specially crafted file.

Releases

Packages

  • rdflib - Pure Python package for working with RDF

Details

Gabriel Corona discovered that RDFLib did not properly load modules on the
command-line. An attacker could possibly use this issue to cause RDFLib to
execute arbitrary code. (CVE-2019-7653)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 16.04

After a standard system update you need to restart any applications that
make use of RDFLib to make all the necessary changes.

References