USN-439-1: file vulnerability

22 March 2007

file vulnerability

Releases

Details

Jean-Sebastien Guay-Leroux discovered that "file" did not correctly
check the size of allocated heap memory. If a user were tricked into
examining a specially crafted file with the "file" utility, a remote
attacker could execute arbitrary code with user privileges.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 6.10
  • libmagic1 - 4.17-2ubuntu1.1
Ubuntu 6.06
  • libmagic1 - 4.16-0ubuntu3.1
Ubuntu 5.10
  • libmagic1 - 4.12-1ubuntu1.1

In general, a standard system upgrade is sufficient to effect the
necessary changes.

References