USN-4239-1: PHP vulnerabilities

15 January 2020

Several security issues were fixed in PHP.

Releases

Packages

  • php5 - HTML-embedded scripting language interpreter
  • php7.0 - HTML-embedded scripting language interpreter
  • php7.2 - HTML-embedded scripting language interpreter
  • php7.3 - server-side, HTML-embedded scripting language (metapackage)

Details

It was discovered that PHP incorrectly handled certain files. An attacker
could possibly use this issue to cause a denial of service. This issue only affected
Ubuntu 14.04 ESM, 16.04 LTS, 18.04 LTS, 19.04 and 19.10. (CVE-2019-11045)

It was discovered that PHP incorrectly handled certain inputs. An attacker
could possibly use this issue to expose sensitive information.
(CVE-2019-11046)

It was discovered that PHP incorrectly handled certain images. An attacker
could possibly use this issue to access sensitive information.
(CVE-2019-11047, CVE-2019-11050)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 19.10
Ubuntu 19.04
Ubuntu 18.04
Ubuntu 16.04
Ubuntu 14.04
Ubuntu 12.04

In general, a standard system update will make all the necessary changes.