Your submission was sent successfully! Close

USN-4212-1: HAProxy vulnerability

04 December 2019

HAProxy could be made to execute arbitrary code if it received a specially crafted HTTP/2 header.

Releases

Packages

  • haproxy - fast and reliable load balancing reverse proxy

Details

Tim Düsterhus discovered that HAProxy incorrectly handled certain HTTP/2 headers.
An attacker could possibly use this issue to execute arbitrary code through CRLF injection.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 19.10
Ubuntu 19.04
Ubuntu 18.04

In general, a standard system update will make all the necessary changes.

References