USN-4157-1: Linux kernel vulnerabilities

17 October 2019

Several security issues were fixed in the Linux kernel.

Releases

Packages

  • linux - Linux kernel
  • linux-aws - Linux kernel for Amazon Web Services (AWS) systems
  • linux-azure - Linux kernel for Microsoft Azure Cloud systems
  • linux-gcp - Linux kernel for Google Cloud Platform (GCP) systems
  • linux-kvm - Linux kernel for cloud environments
  • linux-raspi2 - Linux kernel for Raspberry Pi 2
  • linux-snapdragon - Linux kernel for Snapdragon processors

Details

Wen Huang discovered that the Marvell Wi-Fi device driver in the Linux
kernel did not properly perform bounds checking, leading to a heap
overflow. A local attacker could use this to cause a denial of service
(system crash) or possibly execute arbitrary code. (CVE-2019-14814,
CVE-2019-14815, CVE-2019-14816)

Matt Delco discovered that the KVM hypervisor implementation in the Linux
kernel did not properly perform bounds checking when handling coalesced
MMIO write operations. A local attacker with write access to /dev/kvm could
use this to cause a denial of service (system crash). (CVE-2019-14821)

Hui Peng and Mathias Payer discovered that the 91x Wi-Fi driver in the
Linux kernel did not properly handle error conditions on initialization,
leading to a double-free vulnerability. A physically proximate attacker
could use this to cause a denial of service (system crash).
(CVE-2019-15504)

It was discovered that the Technisat DVB-S/S2 USB device driver in the
Linux kernel contained a buffer overread. A physically proximate attacker
could use this to cause a denial of service (system crash) or possibly
expose sensitive information. (CVE-2019-15505)

Brad Spengler discovered that a Spectre mitigation was improperly
implemented in the ptrace susbsystem of the Linux kernel. A local attacker
could possibly use this to expose sensitive information. (CVE-2019-15902)

It was discovered that the IPv6 RDS implementation in the Linux kernel did
not properly initialize fields in a data structure returned to user space.
A local attacker could use this to expose sensitive information (kernel
memory). Please note that the RDS protocol is blacklisted in Ubuntu by
default. (CVE-2019-16714)

It was discovered that an integer overflow existed in the Binder
implementation of the Linux kernel, leading to a buffer overflow. A local
attacker could use this to escalate privileges. (CVE-2019-2181)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 19.04

After a standard system update you need to reboot your computer to make
all the necessary changes.

ATTENTION: Due to an unavoidable ABI change the kernel updates have
been given a new version number, which requires you to recompile and
reinstall all third party kernel modules you might have installed.
Unless you manually uninstalled the standard kernel metapackages
(e.g. linux-generic, linux-generic-lts-RELEASE, linux-virtual,
linux-powerpc), a standard system upgrade will automatically perform
this as well.

Related notices

  • USN-4162-1: linux-image-generic-hwe-16.04-edge, linux-raspi2, linux-image-4.15.0-1049-raspi2, linux-image-4.15.0-1027-oracle, linux-image-lowlatency-hwe-16.04-edge, linux-image-virtual-hwe-16.04, linux-hwe, linux-image-oem, linux-image-4.15.0-66-generic, linux-kvm, linux-gcp, linux-image-generic-hwe-16.04, linux, linux-image-generic-lpae, linux-image-4.15.0-1047-gcp, linux-image-gke-4.15, linux-image-generic-lpae-hwe-16.04, linux-azure, linux-image-aws, linux-image-aws-hwe, linux-image-gcp, linux-oem, linux-aws, linux-image-4.15.0-1061-azure, linux-image-lowlatency-hwe-16.04, linux-image-virtual, linux-image-generic, linux-image-4.15.0-66-lowlatency, linux-image-4.15.0-1046-gke, linux-image-4.15.0-1066-snapdragon, linux-gke-4.15, linux-image-azure, linux-image-gke, linux-image-4.15.0-66-generic-lpae, linux-image-4.15.0-1048-kvm, linux-image-4.15.0-1059-oem, linux-image-virtual-hwe-16.04-edge, linux-image-oracle, linux-image-raspi2, linux-aws-hwe, linux-image-kvm, linux-oracle, linux-image-generic-lpae-hwe-16.04-edge, linux-image-snapdragon, linux-image-lowlatency, linux-image-4.15.0-1052-aws, linux-snapdragon
  • USN-4162-2: linux-image-4.15.0-1061-azure, linux-azure, linux-image-azure
  • USN-4163-1: linux-raspi2, linux-image-generic-lts-utopic, linux-image-powerpc64-emb, linux-image-powerpc-e500mc-lts-vivid, linux-image-4.4.0-166-powerpc-smp, linux-image-powerpc-smp, linux-image-virtual-lts-wily, linux-image-4.4.0-166-powerpc64-emb, linux-image-powerpc-e500mc, linux-image-powerpc64-emb-lts-wily, linux-image-powerpc64-smp-lts-xenial, linux-image-powerpc-e500mc-lts-utopic, linux-kvm, linux-image-powerpc64-smp-lts-utopic, linux-image-4.4.0-1096-aws, linux-image-4.4.0-166-generic, linux-image-generic-lpae, linux, linux-image-powerpc-e500mc-lts-xenial, linux-image-virtual-lts-utopic, linux-image-powerpc64-emb-lts-xenial, linux-image-4.4.0-1060-kvm, linux-image-lowlatency-lts-utopic, linux-image-generic-lpae-lts-vivid, linux-image-aws, linux-image-lowlatency-lts-xenial, linux-aws, linux-image-virtual, linux-image-generic, linux-image-powerpc64-smp-lts-vivid, linux-image-generic-lpae-lts-xenial, linux-image-generic-lts-xenial, linux-image-generic-lts-wily, linux-image-lowlatency-lts-vivid, linux-image-4.4.0-1124-raspi2, linux-image-generic-lpae-lts-wily, linux-image-powerpc64-emb-lts-utopic, linux-image-powerpc-smp-lts-xenial, linux-image-4.4.0-166-powerpc-e500mc, linux-image-powerpc64-smp, linux-image-generic-lpae-lts-utopic, linux-image-raspi2, linux-image-generic-lts-vivid, linux-image-4.4.0-166-lowlatency, linux-image-kvm, linux-image-powerpc-smp-lts-vivid, linux-image-virtual-lts-vivid, linux-image-snapdragon, linux-image-lowlatency, linux-image-powerpc64-smp-lts-wily, linux-image-lowlatency-lts-wily, linux-image-powerpc64-emb-lts-vivid, linux-image-virtual-lts-xenial, linux-snapdragon, linux-image-powerpc-e500mc-lts-wily, linux-image-powerpc-smp-lts-wily, linux-image-4.4.0-166-powerpc64-smp, linux-image-powerpc-smp-lts-utopic, linux-image-4.4.0-166-generic-lpae, linux-image-4.4.0-1128-snapdragon
  • USN-4163-2: linux-image-4.4.0-166-powerpc-smp, linux-image-4.4.0-166-powerpc64-emb, linux-image-powerpc64-smp-lts-xenial, linux-image-4.4.0-166-generic, linux-image-powerpc-e500mc-lts-xenial, linux-image-powerpc64-emb-lts-xenial, linux-image-aws, linux-image-lowlatency-lts-xenial, linux-aws, linux-lts-xenial, linux-image-generic-lpae-lts-xenial, linux-image-generic-lts-xenial, linux-image-powerpc-smp-lts-xenial, linux-image-4.4.0-166-powerpc-e500mc, linux-image-4.4.0-166-lowlatency, linux-image-4.4.0-1056-aws, linux-image-virtual-lts-xenial, linux-image-4.4.0-166-powerpc64-smp, linux-image-4.4.0-166-generic-lpae
  • USN-4157-2: linux-gke-5.0, linux-image-5.0.0-1021-gcp, linux-image-virtual-hwe-18.04, linux-image-5.0.0-1023-gke, linux-image-generic-lpae-hwe-18.04, linux-azure, linux-image-5.0.0-32-generic, linux-image-azure, linux-image-5.0.0-32-generic-lpae, linux-image-gcp, linux-image-lowlatency-hwe-18.04, linux-hwe, linux-image-5.0.0-1023-azure, linux-image-5.0.0-32-lowlatency, linux-image-generic-hwe-18.04, linux-image-gke-5.0, linux-image-snapdragon-hwe-18.04, linux-gcp