USN-4103-2: Docker vulnerability

19 August 2019

Docker could be made to crash or run programs as your login.

Releases

Packages

  • docker.io - Linux container runtime

Details

Jasiel Spelman discovered that a double free existed in the docker-credential-
helpers dependency of Docker. A local attacker could use this to cause a denial of service
(crash) or possibly execute arbitrary code.

Original advisory details:

Jasiel Spelman discovered that a double free existed in docker-credential-
helpers. A local attacker could use this to cause a denial of service
(crash) or possibly execute arbitrary code.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 19.04
Ubuntu 18.04
Ubuntu 16.04

In general, a standard system update will make all the necessary changes.

References

Related notices

  • USN-4103-1: golang-github-docker-docker-credential-helpers, golang-docker-credential-helpers