USN-4003-1: Qt vulnerabilities

03 June 2019

Several security issues were fixed in Qt.

Releases

Packages

  • qtbase-opensource-src - Qt 5 libraries

Details

It was discovered that Qt incorrectly handled certain XML documents. A
remote attacker could use this issue with a specially crafted XML document
to cause Qt to crash, resulting in a denial of service, or possibly execute
arbitrary code. (CVE-2018-15518)

It was discovered that Qt incorrectly handled certain GIF images. A remote
attacker could use this issue with a specially crafted GIF image to cause
Qt to crash, resulting in a denial of service, or possibly execute
arbitrary code. (CVE-2018-19870)

It was discovered that Qt incorrectly handled certain BMP images. A remote
attacker could use this issue with a specially crafted BMP image to cause
Qt to crash, resulting in a denial of service, or possibly execute
arbitrary code. (CVE-2018-19873)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 18.10
Ubuntu 18.04
Ubuntu 16.04

After a standard system update you need to restart yoursession to make all
the necessary changes.