USN-3954-1: FreeRADIUS vulnerabilities

24 April 2019

FreeRADIUS could be made to bypass authentication if it received a specially crafted input.

Releases

Packages

  • freeradius - high-performance and highly configurable RADIUS server

Details

It was discovered that FreeRADIUS incorrectly handled certain inputs.
An attacker could possibly use this issue to bypass authentication.
(CVE-2019-11234, CVE-2019-11235)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 19.04
Ubuntu 18.10
Ubuntu 18.04

In general, a standard system update will make all the necessary changes.