USN-3849-1: Linux kernel vulnerabilities

20 December 2018

Several security issues were fixed in the Linux kernel.

Releases

Packages

  • linux - Linux kernel

Details

It was discovered that a NULL pointer dereference existed in the keyring
subsystem of the Linux kernel. A local attacker could use this to cause a
denial of service (system crash). (CVE-2017-2647)

It was discovered that a race condition existed in the raw MIDI driver for
the Linux kernel, leading to a double free vulnerability. A local attacker
could use this to cause a denial of service (system crash) or possibly
execute arbitrary code. (CVE-2018-10902)

It was discovered that an integer overrun vulnerability existed in the
POSIX timers implementation in the Linux kernel. A local attacker could use
this to cause a denial of service. (CVE-2018-12896)

Noam Rathaus discovered that a use-after-free vulnerability existed in the
Infiniband implementation in the Linux kernel. An attacker could use this
to cause a denial of service (system crash). (CVE-2018-14734)

It was discovered that the YUREX USB device driver for the Linux kernel did
not properly restrict user space reads or writes. A physically proximate
attacker could use this to cause a denial of service (system crash) or
possibly execute arbitrary code. (CVE-2018-16276)

Tetsuo Handa discovered a logic error in the TTY subsystem of the Linux
kernel. A local attacker with access to pseudo terminal devices could use
this to cause a denial of service. (CVE-2018-18386)

Kanda Motohiro discovered that writing extended attributes to an XFS file
system in the Linux kernel in certain situations could cause an error
condition to occur. A local attacker could use this to cause a denial of
service. (CVE-2018-18690)

It was discovered that an integer overflow vulnerability existed in the
CDROM driver of the Linux kernel. A local attacker could use this to expose
sensitive information (kernel memory). (CVE-2018-18710)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 14.04

After a standard system update you need to reboot your computer to make
all the necessary changes.

ATTENTION: Due to an unavoidable ABI change the kernel updates have
been given a new version number, which requires you to recompile and
reinstall all third party kernel modules you might have installed.
Unless you manually uninstalled the standard kernel metapackages
(e.g. linux-generic, linux-generic-lts-RELEASE, linux-virtual,
linux-powerpc), a standard system upgrade will automatically perform
this as well.

Related notices

  • USN-3797-1: linux-raspi2, linux-image-lowlatency, linux-image-powerpc-e500mc, linux-image-4.4.0-138-powerpc64-smp, linux-image-powerpc64-smp, linux-image-snapdragon, linux-image-4.4.0-138-powerpc64-emb, linux, linux-image-kvm, linux-image-4.4.0-138-powerpc-smp, linux-image-powerpc64-emb, linux-snapdragon, linux-image-4.4.0-138-generic, linux-image-generic-lpae, linux-image-4.4.0-138-powerpc-e500mc, linux-image-4.4.0-1099-raspi2, linux-image-powerpc-smp, linux-image-aws, linux-image-4.4.0-138-generic-lpae, linux-image-4.4.0-1036-kvm, linux-aws, linux-image-4.4.0-1103-snapdragon, linux-image-4.4.0-1070-aws, linux-image-raspi2, linux-image-generic, linux-kvm, linux-image-4.4.0-138-lowlatency
  • USN-3776-2: linux-lts-xenial, linux-image-generic-lpae-lts-xenial, linux-image-4.4.0-1031-aws, linux-image-4.4.0-137-generic-lpae, linux-aws, linux-image-4.4.0-137-powerpc64-emb, linux-image-4.4.0-137-powerpc64-smp, linux-image-generic-lts-xenial, linux-image-powerpc-smp-lts-xenial, linux-image-powerpc64-smp-lts-xenial, linux-image-powerpc64-emb-lts-xenial, linux-image-4.4.0-137-generic, linux-image-lowlatency-lts-xenial, linux-image-4.4.0-137-lowlatency, linux-image-4.4.0-137-powerpc-e500mc, linux-image-aws, linux-image-4.4.0-137-powerpc-smp, linux-image-powerpc-e500mc-lts-xenial
  • USN-3847-1: linux-raspi2, linux-image-4.15.0-1036-azure, linux-image-lowlatency, linux-image-4.15.0-1031-aws, linux-image-4.15.0-1030-raspi2, linux-image-snapdragon, linux-gcp, linux-image-4.15.0-1026-gcp, linux-azure, linux-image-4.15.0-43-snapdragon, linux, linux-image-kvm, linux-image-gke, linux-image-4.15.0-1028-kvm, linux-image-generic-lpae, linux-image-azure, linux-oem, linux-image-aws, linux-image-gcp, linux-image-4.15.0-43-lowlatency, linux-image-4.15.0-43-generic, linux-aws, linux-image-raspi2, linux-image-generic, linux-image-4.15.0-1030-oem, linux-kvm, linux-image-oem, linux-image-4.15.0-43-generic-lpae
  • USN-3847-3: linux-azure, linux-image-4.15.0-1036-azure, linux-image-azure
  • USN-3848-2: linux-lts-xenial, linux-image-4.4.0-141-powerpc-e500mc, linux-image-generic-lpae-lts-xenial, linux-aws, linux-image-4.4.0-141-generic, linux-image-4.4.0-141-powerpc64-emb, linux-image-4.4.0-141-lowlatency, linux-image-generic-lts-xenial, linux-image-4.4.0-141-powerpc-smp, linux-image-powerpc-smp-lts-xenial, linux-image-powerpc64-smp-lts-xenial, linux-image-4.4.0-1037-aws, linux-image-lowlatency-lts-xenial, linux-image-powerpc64-emb-lts-xenial, linux-image-aws, linux-image-powerpc-e500mc-lts-xenial, linux-image-4.4.0-141-generic-lpae, linux-image-4.4.0-141-powerpc64-smp
  • USN-3848-1: linux-image-4.4.0-141-powerpc64-emb, linux-raspi2, linux-image-4.4.0-1039-kvm, linux-image-lowlatency, linux-image-4.4.0-1102-raspi2, linux-image-powerpc-e500mc, linux-image-powerpc64-smp, linux-image-4.4.0-141-powerpc64-smp, linux-image-snapdragon, linux-image-4.4.0-141-powerpc-e500mc, linux, linux-image-kvm, linux-image-powerpc64-emb, linux-snapdragon, linux-image-4.4.0-141-generic-lpae, linux-image-generic-lpae, linux-image-4.4.0-141-generic, linux-image-4.4.0-141-powerpc-smp, linux-image-powerpc-smp, linux-image-aws, linux-aws, linux-image-4.4.0-1074-aws, linux-image-raspi2, linux-image-4.4.0-141-lowlatency, linux-image-generic, linux-kvm, linux-image-4.4.0-1106-snapdragon
  • USN-3797-2: linux-lts-xenial, linux-image-generic-lpae-lts-xenial, linux-image-4.4.0-1032-aws, linux-image-4.4.0-138-powerpc-e500mc, linux-aws, linux-image-4.4.0-138-generic-lpae, linux-image-generic-lts-xenial, linux-image-4.4.0-138-powerpc64-emb, linux-image-powerpc-smp-lts-xenial, linux-image-powerpc64-smp-lts-xenial, linux-image-aws, linux-image-4.4.0-138-powerpc-smp, linux-image-lowlatency-lts-xenial, linux-image-powerpc64-emb-lts-xenial, linux-image-4.4.0-138-lowlatency, linux-image-4.4.0-138-powerpc64-smp, linux-image-powerpc-e500mc-lts-xenial, linux-image-4.4.0-138-generic
  • USN-3847-2: linux-hwe, linux-image-generic-lpae-hwe-16.04, linux-image-gcp, linux-gcp, linux-aws-hwe, linux-azure, linux-image-4.15.0-1026-gcp, linux-image-4.15.0-1036-azure, linux-image-generic-hwe-16.04, linux-image-azure, linux-image-lowlatency-hwe-16.04, linux-image-gke, linux-image-aws-hwe, linux-image-4.15.0-1031-aws, linux-image-4.15.0-43-generic-lpae, linux-image-4.15.0-43-lowlatency, linux-image-4.15.0-43-generic
  • USN-3849-2: linux-lts-trusty, linux-image-generic-lts-trusty, linux-image-3.13.0-164-generic, linux-image-generic-lpae-lts-trusty, linux-image-3.13.0-164-generic-lpae
  • USN-3846-1: linux-raspi2, linux-image-lowlatency, linux-image-4.18.0-13-generic, linux-image-snapdragon, linux-gcp, linux-azure, linux, linux-image-kvm, linux-image-gke, linux-image-4.18.0-1006-kvm, linux-image-generic-lpae, linux-image-4.18.0-13-lowlatency, linux-image-4.18.0-13-snapdragon, linux-image-azure, linux-image-4.18.0-1007-aws, linux-image-4.18.0-13-generic-lpae, linux-image-aws, linux-image-gcp, linux-aws, linux-image-raspi2, linux-image-4.18.0-1005-gcp, linux-image-4.18.0-1008-raspi2, linux-image-generic, linux-kvm, linux-image-4.18.0-1007-azure
  • USN-3776-1: linux-raspi2, linux-image-4.4.0-1035-kvm, linux-image-lowlatency, linux-image-4.4.0-1102-snapdragon, linux-image-powerpc-e500mc, linux-image-4.4.0-137-powerpc-smp, linux-image-powerpc64-smp, linux-image-snapdragon, linux-image-4.4.0-137-generic-lpae, linux-image-4.4.0-137-powerpc64-emb, linux, linux-image-kvm, linux-image-4.4.0-1098-raspi2, linux-image-4.4.0-137-lowlatency, linux-image-powerpc64-emb, linux-snapdragon, linux-image-generic-lpae, linux-image-4.4.0-137-generic, linux-image-powerpc-smp, linux-image-aws, linux-aws, linux-image-raspi2, linux-image-4.4.0-137-powerpc64-smp, linux-image-generic, linux-image-4.4.0-1069-aws, linux-kvm, linux-image-4.4.0-137-powerpc-e500mc