USN-3782-1: Liblouis vulnerabilities

03 October 2018

Several security issues were fixed in Liblouis.

Releases

Packages

  • liblouis - Braille translation library - utilities

Details

Henri Salo discovered that Liblouis incorrectly handled certain files.
An attacker could possibly use this issue to execute arbitrary code.
(CVE-2018-12085)

It was discovered that Liblouis incorrectly handled certain files.
An attacker could possibly use this issue to cause a denial of service.
This issue only affected Ubuntu 18.04 LTS. (CVE-2018-17294)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 18.04
Ubuntu 16.04
Ubuntu 14.04

In general, a standard system update will make all the necessary changes.