USN-3744-1: PostgreSQL vulnerabilities

16 August 2018

Several security issues were fixed in PostgreSQL.

Releases

Packages

  • postgresql-10 - object-relational SQL database
  • postgresql-9.3 - Object-relational SQL database
  • postgresql-9.5 - Object-relational SQL database

Details

Andrew Krasichkov discovered that the PostgreSQL client library incorrectly
reset its internal state between connections. A remote attacker could
possibly use this issue to bypass certain client-side connection security
features. This issue only affected Ubuntu 16.04 LTS and Ubuntu 18.04 LTS.
(CVE-2018-10915)

It was discovered that PostgreSQL incorrectly checked authorization on
certain statements. A remote attacker could possibly use this issue to
read arbitrary server memory or alter certain data. (CVE-2018-10925)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 18.04
Ubuntu 16.04
Ubuntu 14.04

This update uses a new upstream release, which includes additional bug
fixes. After a standard system update you need to restart PostgreSQL to
make all the necessary changes.