Your submission was sent successfully! Close

USN-3699-1: zziplib vulnerabilities

3 July 2018

zziplib could be made to crash or run programs as your login if it opened a specially crafted file.

Releases

Packages

  • zziplib - library providing read access on ZIP-archives - library

Details

It was discovered that zziplib incorrectly handled certain malformed ZIP
files. If a user or automated system were tricked into opening a specially
crafted ZIP file, a remote attacker could cause zziplib to crash, resulting
in a denial of service, or possibly execute arbitrary code.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 18.04
Ubuntu 17.10
Ubuntu 16.04
Ubuntu 14.04

In general, a standard system update will make all the necessary changes.