USN-363-1: libmusicbrainz vulnerability

11 October 2006

libmusicbrainz vulnerability

Releases

Details

Luigi Auriemma discovered multiple buffer overflows in libmusicbrainz.
When a user made queries to MusicBrainz servers, it was possible for
malicious servers, or man-in-the-middle systems posing as servers, to
send a crafted reply to the client request and remotely gain access to
the user's system with the user's privileges.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 6.06
  • libmusicbrainz4c2a - 2.1.2-2ubuntu3.1
Ubuntu 5.10
  • libmusicbrainz2c2 - 2.0.2-10ubuntu2.1
  • libmusicbrainz4c2 - 2.1.1-3ubuntu3.1
Ubuntu 5.04
  • libmusicbrainz2 - 2.0.2-10ubuntu1.1
  • libmusicbrainz4 - 2.1.1-3ubuntu1.1

After a standard system upgrade you need to restart your session to
effect the necessary changes.

References