Your submission was sent successfully! Close

You have successfully unsubscribed! Close

USN-3600-1: PHP vulnerabilities

19 March 2018

Several security issues were fixed in PHP.

Reduce your security exposure

Ubuntu Pro provides ten-year security coverage to 25,000+ packages in Main and Universe repositories, and it is free for up to five machines.

Learn more about Ubuntu Pro

Releases

Packages

  • php5 - HTML-embedded scripting language interpreter
  • php7.0 - HTML-embedded scripting language interpreter
  • php7.1 - HTML-embedded scripting language interpreter

Details

It was discovered that PHP incorrectly handled certain stream metadata. A
remote attacker could possibly use this issue to set arbitrary metadata.
This issue only affected Ubuntu 14.04 LTS. (CVE-2016-10712)

It was discovered that PHP incorrectly handled the PHAR 404 error page. A
remote attacker could possibly use this issue to conduct cross-site
scripting (XSS) attacks. This issue only affected Ubuntu 16.04 LTS and
Ubuntu 17.10. (CVE-2018-5712)

It was discovered that PHP incorrectly handled parsing certain HTTP
responses. A remote attacker could use this issue to cause PHP to crash,
resulting in a denial of service, or possibly execute arbitrary code.
(CVE-2018-7584)

Reduce your security exposure

Ubuntu Pro provides ten-year security coverage to 25,000+ packages in Main and Universe repositories, and it is free for up to five machines.

Learn more about Ubuntu Pro

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 17.10
Ubuntu 16.04
Ubuntu 14.04

In Ubuntu 16.04 LTS and Ubuntu 17.10, this update uses a new upstream
release, which includes additional bug fixes.

In general, a standard system update will make all the necessary changes.

Related notices

  • USN-3566-2: php5-dev, php5-mysql, php5-mysqlnd, php5-gmp, php5-tidy, libapache2-mod-php5filter, php5-xmlrpc, php5-sybase, php5-gd, php5-odbc, libphp5-embed, php-pear, php5-common, php5-sqlite, php5-cgi, php5-curl, php5-fpm, php5-recode, php5-xsl, php5-pspell, php5-ldap, php5, php5-readline, php5-snmp, php5-pgsql, libapache2-mod-php5, php5-intl, php5-enchant, php5-cli
  • USN-3600-2: php5, php5-cgi, php5-fpm, libapache2-mod-php5, php5-cli
  • USN-3566-1: php5-dev, php5-mysql, php5-mysqlnd, php5-gmp, php5-tidy, libapache2-mod-php5filter, php5-xmlrpc, php5-sybase, php5-gd, php5-odbc, libphp5-embed, php-pear, php5-common, php5-sqlite, php5-cgi, php5-curl, php5-fpm, php5-recode, php5-xsl, php5-pspell, php5-ldap, php5, php5-readline, php5-snmp, php5-pgsql, libapache2-mod-php5, php5-intl, php5-enchant, php5-cli