USN-3347-1: Libgcrypt vulnerabilities

03 July 2017

libgcrypt11, libgcrypt20 vulnerabilities

Packages

  • libgcrypt11 - LGPL Crypto library
  • libgcrypt20 - LGPL Crypto library

Details

Daniel J. Bernstein, Joachim Breitner, Daniel Genkin, Leon Groot
Bruinderink, Nadia Heninger, Tanja Lange, Christine van Vredendaal, and
Yuval Yarom discovered that Libgcrypt was susceptible to an attack via
side channels. A local attacker could use this attack to recover RSA
private keys. (CVE-2017-7526)

It was discovered that Libgcrypt was susceptible to an attack via
side channels. A local attacker could use this attack to possibly recover
EdDSA private keys. This issue only applied to Ubuntu 16.04 LTS, Ubuntu
16.10 and Ubuntu 17.04. (CVE-2017-9526)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 17.04
Ubuntu 16.10
Ubuntu 16.04
Ubuntu 14.04

In general, a standard system update will make all the necessary changes.