USN-2949-1: Linux kernel (Vivid HWE) vulnerabilities

06 April 2016

Several security issues were fixed in the kernel.

Releases

Packages

  • linux-lts-vivid - Linux hardware enablement kernel from Vivid for Trusty

Details

Venkatesh Pottem discovered a use-after-free vulnerability in the Linux
kernel's CXGB3 driver. A local attacker could use this to cause a denial of
service (system crash) or possibly execute arbitrary code. (CVE-2015-8812)

Xiaofei Rex Guo discovered a timing side channel vulnerability in the Linux
Extended Verification Module (EVM). An attacker could use this to affect
system integrity. (CVE-2016-2085)

David Herrmann discovered that the Linux kernel incorrectly accounted file
descriptors to the original opener for in-flight file descriptors sent over
a unix domain socket. A local attacker could use this to cause a denial of
service (resource exhaustion). (CVE-2016-2550)

It was discovered that the Linux kernel did not enforce limits on the
amount of data allocated to buffer pipes. A local attacker could use this
to cause a denial of service (resource exhaustion). (CVE-2016-2847)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 14.04

After a standard system update you need to reboot your computer to make
all the necessary changes.

ATTENTION: Due to an unavoidable ABI change the kernel updates have
been given a new version number, which requires you to recompile and
reinstall all third party kernel modules you might have installed.
Unless you manually uninstalled the standard kernel metapackages
(e.g. linux-generic, linux-generic-lts-RELEASE, linux-virtual,
linux-powerpc), a standard system upgrade will automatically perform
this as well.

Related notices

  • USN-2946-1: linux-image-3.13.0-85-powerpc64-smp, linux-image-3.13.0-85-generic-lpae, linux-image-3.13.0-85-generic, linux-image-3.13.0-85-powerpc-e500, linux-image-3.13.0-85-powerpc64-emb, linux-image-3.13.0-85-powerpc-smp, linux, linux-image-3.13.0-85-powerpc-e500mc, linux-image-3.13.0-85-lowlatency
  • USN-2947-2: linux-image-4.2.0-35-generic-lpae, linux-image-4.2.0-35-generic, linux-image-4.2.0-35-lowlatency, linux-image-4.2.0-35-powerpc-smp, linux-lts-wily, linux-image-4.2.0-35-powerpc64-smp, linux-image-4.2.0-35-powerpc64-emb, linux-image-4.2.0-35-powerpc-e500mc
  • USN-2946-2: linux-lts-trusty, linux-image-3.13.0-85-generic-lpae, linux-image-3.13.0-85-generic
  • USN-2967-1: linux-image-3.2.0-102-generic, linux-image-3.2.0-102-highbank, linux-image-3.2.0-102-omap, linux-image-3.2.0-102-virtual, linux-image-3.2.0-102-generic-pae, linux-image-3.2.0-102-powerpc-smp, linux-image-3.2.0-102-powerpc64-smp, linux
  • USN-2948-1: linux-image-3.16.0-69-powerpc64-smp, linux-image-3.16.0-69-lowlatency, linux-image-3.16.0-69-generic, linux-image-3.16.0-69-powerpc64-emb, linux-image-3.16.0-69-powerpc-e500mc, linux-lts-utopic, linux-image-3.16.0-69-generic-lpae, linux-image-3.16.0-69-powerpc-smp
  • USN-2965-2: linux-lts-xenial, linux-image-4.4.0-22-generic, linux-image-4.4.0-22-lowlatency, linux-image-4.4.0-22-generic-lpae, linux-image-4.4.0-22-powerpc-smp, linux-image-4.4.0-22-powerpc64-smp, linux-image-4.4.0-22-powerpc-e500mc, linux-image-4.4.0-22-powerpc64-emb
  • USN-2947-3: linux-raspi2, linux-image-4.2.0-1028-raspi2
  • USN-2947-1: linux-image-4.2.0-35-generic-lpae, linux-image-4.2.0-35-generic, linux-image-4.2.0-35-lowlatency, linux-image-4.2.0-35-powerpc-smp, linux-image-4.2.0-35-powerpc64-smp, linux-image-4.2.0-35-powerpc64-emb, linux, linux-image-4.2.0-35-powerpc-e500mc
  • USN-2967-2: linux-ti-omap4, linux-image-3.2.0-1480-omap4