Your submission was sent successfully! Close

USN-2657-1: unattended-upgrades vulnerability

29 June 2015

An attacker could trick unattended-upgrades into installing altered packages.

Releases

Packages

Details

It was discovered that unattended-upgrades incorrectly performed
authentication checks in certain configurations. If a remote attacker were
able to perform a machine-in-the-middle attack, this flaw could potentially be
used to install altered packages.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 15.04
Ubuntu 14.10
Ubuntu 14.04
Ubuntu 12.04

In general, a standard system update will make all the necessary changes.

References