USN-2412-1: Ruby vulnerability

20 November 2014

Ruby could be made to consume resources.

Releases

Packages

  • ruby1.8 - Object-oriented scripting language
  • ruby1.9.1 - Object-oriented scripting language
  • ruby2.0 - Object-oriented scripting language
  • ruby2.1 - Object-oriented scripting language

Details

Tomas Hoger discovered that Ruby incorrectly handled XML entity expansion.
An attacker could use this flaw to cause Ruby to consume large amounts of
resources, resulting in a denial of service.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 14.10
Ubuntu 14.04
Ubuntu 12.04

In general, a standard system update will make all the necessary changes.

References