USN-1806-1: OpenJDK 7 vulnerabilities

23 April 2013

Several security issues were fixed in OpenJDK 7.

Releases

Packages

  • openjdk-7 - Open Source Java implementation

Details

Ben Murphy discovered a vulnerability in the OpenJDK JRE related to
information disclosure and data integrity. An attacker could exploit this
to execute arbitrary code. (CVE-2013-0401)

James Forshaw discovered a vulnerability in the OpenJDK JRE related to
information disclosure, data integrity and availability. An attacker could
exploit this to execute arbitrary code. (CVE-2013-1488)

Several vulnerabilities were discovered in the OpenJDK JRE related to
information disclosure, data integrity and availability. An attacker could
exploit these to cause a denial of service or expose sensitive data over
the network. (CVE-2013-1518, CVE-2013-1537, CVE-2013-1557, CVE-2013-1569,
CVE-2013-2383, CVE-2013-2384, CVE-2013-2420, CVE-2013-2421, CVE-2013-2422,
CVE-2013-2426, CVE-2013-2429, CVE-2013-2430, CVE-2013-2431, CVE-2013-2436)

Two vulnerabilities were discovered in the OpenJDK JRE related to
confidentiality. An attacker could exploit these to expose sensitive data
over the network. (CVE-2013-2415, CVE-2013-2424)

Two vulnerabilities were discovered in the OpenJDK JRE related to
availability. An attacker could exploit these to cause a denial of service.
(CVE-2013-2417, CVE-2013-2419)

A vulnerability was discovered in the OpenJDK JRE related to data
integrity. (CVE-2013-2423)

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 12.10

This update uses a new upstream release, which includes additional bug
fixes. After a standard system update you need to restart any Java
applications or applets to make all the necessary changes.

Related notices

  • USN-2522-3: icu, libicu48
  • USN-1819-1: openjdk-6-jre-headless, openjdk-6, icedtea-6-jre-jamvm, openjdk-6-jre-zero, openjdk-6-jre, icedtea-6-jre-cacao, openjdk-6-jre-lib
  • USN-2522-1: icu, libicu52, libicu48