Your submission was sent successfully! Close

USN-1307-1: PHP vulnerability

14 December 2011

PHP could be made to crash or disclose sensitive information if it processed a specially crafted image file.

Releases

Packages

  • php5 - HTML-embedded scripting language interpreter

Details

Florent Hochwelker discovered that PHP incorrectly handled certain EXIF
headers in JPEG files. A remote attacker could exploit this issue to
view sensitive information or cause the PHP server to crash.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 8.04
Ubuntu 11.10
Ubuntu 11.04
Ubuntu 10.10
Ubuntu 10.04

In general, a standard system update will make all the necessary changes.

References