Your submission was sent successfully! Close

USN-1180-1: libvirt vulnerability

28 July 2011

An authenticated attacker could send crafted input to libvirt and cause it to crash.

Releases

Packages

  • libvirt - Libvirt virtualization toolkit

Details

Eric Blake discovered an integer overflow flaw in libvirt. A remote
authenticated attacker could exploit this by sending a crafted VCPU RPC
call and cause a denial of service via application crash.

Update instructions

The problem can be corrected by updating your system to the following package versions:

Ubuntu 11.04
Ubuntu 10.10
Ubuntu 10.04

In general, a standard system update will make all the necessary changes.

References